Vistallation

Prima Erfahrungen bei der Installation von Visual Studio 2008 beta auf Microsoft Vista:

Schritt 1: .img-Datei herunterladen
Soweit klar.
Schritt 2:  .img in .iso umbenennen
Nanu, wieso ist denn das nötig? Aber gut.
Schritt 3: das .iso-File auf DVD brennen
Schön, wie geht das in Vista mit Bordmitteln? Ich finde keine Möglichkeit; die Hilfe hilft nicht. Ich suche zwanzig Minuten, ohne eine Möglichkeit zu finden. Liegt es an mir? Statt weiter zu suchen, besorge ich mir ein Programm, das das kann (ImgBurn) und brenne die DVD.
Schritt 4: Setup, erster Versuch: Fehlermeldung „XP mit SP2 erforderlich“
Wie bitte!? Ich installiere unter Vista! Und die Beta soll ausdrücklich darunter laufen.
Eigentlich habe ich jetzt schon keine Lust mehr, weiterzumachen. Mein Admin ist amüsiert, aber nicht wirklich überrascht: „Google mal ein bisschen.“
Schritt 5: Ich suche nach Fehlerbeschreibungen und Lösungen.
Es scheint haufenweise Probleme bei der Installation zu geben. OK, es ist eine beta. Aber was da an Fehlern und Lösungen beschrieben wird, klingt haarsträubend.
Schritt 6: Ich finde eine Beschreibung genau dieses Fehlers – Hurra…
Super, nun freue ich mich schon über so etwas. Die Lösung? Registry bearbeiten. Oder halt: Erstmal versuchen, ob die Installation klappt, wenn man alle Dateien auf die Platte kopiert.
Schritt 7: Setup, zweiter Versuch: Keine Fehlermeldung, aber Schritt 1 dauert schon über eine Viertelstunde.
Moment, darüber war doch auch etwas zu lesen? „Installation of .NET hangs“. Lösung: Man soll ein bestimmtes Windows-Updates deinstallieren und es dann noch einmal versuchen.
Schritt 8: Ich breche das Setup ab, um das betreffende Update zu deinstallieren. 
Statt einfach abzubrechen, will Setup diesen Schritt noch ausführen. He, wieso breche ich denn ab? OK, ich warte – bereit, dem ein hartes Ende zu setzen. Aber nach einiger Zeit meldet Setup tatsächlich, .net sei installiert, das Setup sei aber abgebrochen.
Schritt 9: Setup, dritter Versuch.
Ich verzichte auf die Deinstallation des erwähnten Updates und starte Setup einfach noch einmal. Und: es läuft diesmal durch.
Schritt 10: Finish.
Das überrascht mich jetzt wirklich: es ist kein Neustart nötig.
Was wohl daran liegt, dass ich nach Schritt 8 neu gestartet habe, weil das System neu installierte Software gemeldet hatte und den Neustart wollte… 

Damit verbringe ich also meine Zeit. Ich gebe ja zu, dass gar nichts mit dem Betriebssystem zu tun haben muss. Aber ich hatte schon so häufig miese Installationserlebnisse unter verschiedenen Windowsversionen, dass ich da doch langsam einen Zusammenhang sehe. Ein besonders schönes Beispiel war das Setup für einen WLAN-Kartentreiber, dessen letzte Meldung immer hieß: „Die Software wurde installiert oder deinstalliert.“ Ohne einen Hinweis beim Start, ob jetzt installiert oder entfernt wird. Der User sollte wohl selbst wissen, was da in welcher Version auf seiner Platte liegt…

Mal sehen, wie es weitergeht. Immerhin will ich ja mit Windows arbeiten. Oder nein: Ich muss, denn Expression Blend gibt es nicht für Mac OS.

Eine Reaktion zu “Vistallation”

  1. Ecki

    Ups, das hört sich verdammt nach geschäftlichen Terminen in München an…

Einen Kommentar schreiben